Problem trying to install Corel Draw Graphics Suite X4

Hi. I've tried dozens of times and in many ways to install CorelDRAW Graphics Suite X4 but I just can't make it. The problem is when the License Agreement Screen appears, it's shown empty. 

Screenshot: 

CorelDRAW Installation Screenshot

I wonder why this is happening. Any ideas? 



[edited by: viru at 13:27 (GMT -7) on Mon, Feb 11 2008]

55 Replies - Latest Reply

  • You might have had a problem with the download... When you launch the installer, do you get a digital signature from Corel or do you get an "Unsigned" message?

    Gérard

  • In reply to Gerard Metrailler:

    I have de same problem.

    I have a Notebook Dell 1520, with vista Home Basic.

    I think that the problem is the Windows Vista Home, because i try to install de same .exe in a windows Vista Ultimate (my home desktop PC) an run fine.

    if anyone can solve the problem please tell me, couse' i need to instal the corel in my notebook and i can't do it.

     

  • In reply to Gerard Metrailler:

    I downloaded CorelDRAW Trial from the Corel site and others location too. The installer has the Corel digital signature.. no messages of that kind.

    I use Windows XP Professional and still have the problem. It's not a Vista problem. No clues...

  • In reply to viru:

    i dont know what it is, becouse i use de same .exe and work fine in other machine, but in my notebook i cant install it. i need a solution.

  • FWIW, I haven't herad of this until now...I've forwarded this to QA to see if they have any ideas.

    T. 

  • In reply to Tony Severenuk:

    Maybe this can help: once I tried installing Autocad 2008, and exactly the same thing happened. An empty screen showed up and couldn't go on with the installation. No problems installing Autocad 2007 and Corel DRAW Graphics Suite X3. Maybe it's something in the installation program. Some kind of language that my machine can't parse.



    [edited by: viru at 17:27 (GMT -7) on Wed, Feb 13 2008]
  • In reply to Tony Severenuk:

     I, too, am having a problem installing X4. This is from an X4 upgrade DVD disk from Corel. Besides taking an eternity to load, CorelDraw hangs upon opening the application. PhotoPaint opens properly. I have done a complete uninstall and reinstall. All the beta versions worked like a charm. No problems with downloading, installing or opening the whole suite... ?

  • In reply to David Pylypiw:

     David:

     Did you hold down F8 on first launch to see if it's a workspace thing? If you had a beta version on the computer then there could be old stuff left on there causing problems.

    T. 

  • In reply to viru:

     Do you have an anti-virus and anti-spamware tools running on your computer during the installation? I recall someone in the forums having problem with the installation until they temporarely disabled these... And in case you ask, part of our standard release procedure is to test for all known viruses at the time of release.

    Gérard 

  • In reply to Gerard Metrailler:

    Do these install screens use any part of IE? I remember someone making a comment about Active X failed something...

    http://support.microsoft.com/kb/947518

    If so maybe that might help. 



    [edited by: Yani at 3:50 (GMT -7) on Fri, Feb 15 2008]
  • I have same problem. Windows xp sp2. Antivirus software (nod32) was disabled.... 

  • In reply to milori:

    http://imagonullius.com/corel-ng/installclean.zip

    I can't tell you why but some during the beta period had no problems with the installer and some had plenty.

    It took me a day to get it to load and even now I can say exactly why it did load on the last try or why it failed on other attempts. But I can tell you after the first failure I wrote a log in the forum as I went so that the issues could be identified.

    Even with that as a guide there were a couple of people who experienced failure on some machines.

     

    Tony you need to go into the beta forum and read http://beta.corel.com/forums/t/1613.aspx 

    OH DEAR...

    starts Draw...

    Product installation unsuccessful, please reinstall (Error 4)

    Same for PP 

    Capture works fine...  I guess that isn't suffering from License Protection.

    Reinstall, remove, repair or just cry like a baby. I can't decide.

     

    From my log...

    WHAT IF INSTEAD OF HITTING I'VE GOT A SERIAL NUMBER... I HIT TRIAL 

    I'll have to go back and read the instructions again but looks like it does work if you select trial and then use the serial number.

     

    At that point I thought we had the problem located but this proved to be false and doing all the above didn't help a few people.

     

     

    It might be related in some way to the copy protection system. (At lease that would seem like the logical place where the issue is generated.)

    It might be to do with the way Windows protects applications so that updates are not lost when reloading from the original disks.

    It might be system restore which was on here.

    It might be Virus or Pest software as mentioned. (I never turn that stuff off)

    Ratio of the issue in the beta group was about 1:100. Pretty clearly it's not been a issue inside Corel, so it might relate to previously installed software which used the same copy protection system.

     

    You can try the above but I'm not making any promise. More important is that you accurately log the process that is occuring and look for what might be common between your systems. 

     

    Uninstall X4 - don't repair that won't help

    • Use the couple of tools in that zip file they clean out previous installs
    • Delete all Corel X4 files in the program directory...
      • C:\Program Files\Corel\CorelDRAW Graphics Suite X4
      • C:\Program Files\Corel\CorelDRAW Graphics Suite X4 Setup Files 
    • Delete C:\Documents and Settings\username\Application Data\Corel\CorelDRAW Graphics Suite X4
    • Delete all Temp files C:\Documents and Settings\username\Local Settings\Temp 
    • Run a disk Error-Checking (Right click disk / Properties / Error-checking)
    Try again - accurately log the process and report back

     

  • In reply to Tony Severenuk:

     Thank you Tony;

    Holding down the F8 key while loading CorelDraw, did the trick.
    Now opens properly, a little slow... but okay.

    Many thanks,
    David Pylypiw, Cambridge Ontario
    --------------------------------------------------------------------------------------

  • In reply to David Pylypiw:

    I have the trial version and I can't seem to get the installer to load even, I'm using XP sp2 and I have IE7 and I don't have anything running practically and it won't load.. it just says something like.. 

    >setupnex\setup.cpp(135)

    papp:

    Pvendor:

    pguid:

    $

    @windows XP service pack 2 (2600) IE 7.0.6000.16608 

     

    amd then it prompty won't even load. 

     

    Edit: well it seems that this was a installer problem.. just downloaded a freas copy and it works. 

     

    Edit 2: Well this is my 3rd download and they all have had issues, it seems to stop after it gets about half way, has an error about there being no CD and then if you ignore it says that there is a corrupt or missing file. 



    [edited by: nate at 20:29 (GMT -7) on Sun, Feb 17 2008]
  • In reply to nate:

    Nate, where are you downloading the trial from?

    Are you using a download accelerator program?

    Gérard