• Not Answered

Cannot Uninstall Corrupted Corel X5

I posted an issue I was having with Corel Draw X5 about a week ago and the issue seems to persist.

I did a clean install of Windows 7 Pro (64 bit) on a custom built system I have had for a year. It is running 8 Gigs of RAM on an AMD Phenom II X6 (six core) processor. All programs are on a 120 Gig SSD hard drive and all data on a 1.5 TB hard drive. So there are no hardware or system deficiencies that should get in the way of running Corel Draw X5.

I bought the Corel X5 program after installing a trial version. I have had previous versions of Corel (9.0 and 12) so I am reasonably familiar with its peculiarities.

After purchasing the X5 disk I removed the trial version (or so I thought) and attempted to do a clean install of the program.

in a previous post I was having an issue with producing PDF documents with X5. I would go through the labor of laying everything out and do a "publish to PDF with the default "Document Distribution" settings. Nothing fancy. When I would go to open the document in Acrobat X Pro it would say "There was an error opening this document. The document is damaged and could not be repaired".

I tried doing a full uninstall of the program and remove all used files in the uninstall utility. I also deleted all folders in application data, program files and anywhere else that Corel showed up. I ran CCleaner to remove any errant registry files that were not being used as a result of the uninstall. .

Then I did a full "Clean" install of X5. What I saw first was that there were a couple of template files still there when I opened the program which should have been nuked after deleting Corel folder in the 'Programs Files (x86)' directory.

I did this now 3 times and I cannot get a clean install and the problem with the corrupt PDF output still persists.

==================================================================
Is ther any way to completely remove Corel Draw X5 so I can do a
clean install for real and hopefully get this problem to go away?
==================================================================

HELP!!!!


Peter

 

5 Replies - Latest Reply

  • After your latest install, did you also install the service packs and hotfix 4 ?



    [edited by: harryLondon at 19:26 (GMT -5) on Tue, Jan 22 2013]
  • In reply to harryLondon:

    Harry,

     

    Indeed I did. I even was wondering if the update and the hotfix CAUSED the issue.

     

    Peter

  • I think that's unlikely, but my CorelDraw is X4 and X6 so I can only say that others seem to have used  it with all the updates and without problems.

    Is your .net installation up to date? X5 I think uses .net 4.0 which has updates at http://www.microsoft.com/en-gb/download/details.aspx?id=29053 and also a general windows update check.

    Installing CorelDraw does not update user preferences and settings (because mostly, people want to keep them). But you can reset those at any time, by holding F8 when starting CorelDraw.

    If none of that works, there isn't an official "total uninstaller" but the general procedure would be log on as administrator and:

    • Remove whatever you can, using the standard uninstaller
    • Search for all folders containing the word CorelDraw and remove them (but first, make sure you don't have any .CDR files saved there). You need to remove folders in the user tree (including both yourself and the all users tree) as well as the Programs and ProgramData trees.
    • With the registry editor (and carefully), search for CorelDraw and remove any whole branches that contain the word.
    • Use cCleaner's registry check to remove leftover registry entries outside the CorelDraw branches that relate to CorelDraw
    • Repeat cCleaner registry check several times until no further errors are found (or, it finds the same errors for the third time).
    • Reboot and run cCleaner again.

     

     

     



    [edited by: harryLondon at 5:43 (GMT -5) on Wed, Jan 23 2013]
  • In reply to harryLondon:

    Harry,

    I checked and updated my DOT NET to 4.5. I recreated a 15 page document with graphics FROM SCRATCH thinking that some of the assets may have touched one of the previous installations and was somehow corrupted. I was encouraged when step by step I would take a page of plain text, format then publish to PDF and it would work fine. I went ahead and added each component and publish after each step with a new file name when I published to PDF. After the second page it again was incapable of publishing to PDF. Out of curiosity I installed Corel X5 on another machine clean(no previous Corel installation). It runs doggedly slow since the machine is Win 7 with 4 Gigs of RAM. I opened the files crated and published to PDF and there was no problem. So I conclude that the install is off somehow and I need to get the old corrupt installation off of it.  So it takes me back to square one which is achieving a COMPLETE uninstall with no vestiges of the old installation gone so I can get a clean and uncorrupted installation accomplished.

    Thanks,

    Peter

  • In reply to pvb8:

    Knowing microsoft's track record, .net 4.5 probably isn't fully backwards compatible with 4.0 -- so installing it instead of 4.0 may not be sufficient. 4.5 would not have been around when X5 was developed, so the two would never have been tested together.