Some of the Fonts not displaying properly since windows updates installed today. 12.12.12

I got calls from 3 of the DRAW users that some of the fonts are not displaying correctly since they have updated their Windows today. I have not yet connected my laptop to internet. Shall check it and try to identify the culprit update. Any light on this is appreciated.

Few fonts known for not displaying correctly since today

Diavlo_MEDIUM_II_37.otf and its family with light, black etc.
Myriaid PRO

 

  • In reply to drummachine:

    drummachine
    The affected Microsoft-Update on my Windows 7 x64 system is KB2753842.

    Thank you for checking this out. Uninstalling KB2753842 brings Draw back to normal. Of course, Windows Update wants to re-install it. I set it to manual installation, but this is no solution, it is a security update, classified "important".

  • In reply to Watzmann:

    Watzmann
    Of course, Windows Update wants to re-install it.

    In Windows Update you can right-click on an update and choose "Don't show me this update again" and it will not be offered to you again. There is always the option to "Show Me Hidden Updates" if you later decide you want to download it.

    Best regards,
    Brian.

  • In reply to Drew F.:

    I have now completed all the rest of the updates in this list and verified both 32bit and 64bit CorelDRAW versions and indeed it is KB2753842 since that was the only update I did not install on either machine.

  • In reply to kerrdelune:

    The only way I know for sure works, because I did this myself, is to use Windows Restore and roll back to the last restore point before the update. If you have System Restore turned off, then you may wish to try Control Panel > Programs > Programs and Features > Installed Updates and then highlight the installed update and then uninstall it. I would have personally tried that method first but I chose the easy way out and did a System Restore. If I were you, I'd look in the list of updates and uninstall just that one first and that way if it works then you don't have to reinstall all Windows updates again, unchecking the problematic KB2753842 update.

    Also, go to your Control Panel > All Control Panel Items > WIndows Update settings and select Change Settings from the sidebar. From there look for Important Updates and make sure you select Check for updates but let me choose when to install them or just shut them off (Never check for updates) until this gets worked out. It will be up to you to keep checking here until a solution is offered that works and then you can turn them back on.



    [edited by: Drew F. at 15:59 (GMT -5) on Wed, Dec 12 2012]
  • In reply to Drew F.:

    I can confirm that removing Windows update KB2753842 fixed the issue for me. Fonts appear properly now.

  • In reply to john_schneider:

    John:

    Corel is not investigating at this point...we logged a call with MS to find out what happened and we are awaiting news.

    T.

  • In reply to Drew F.:

    Hello guys!

    We take this issue very seriously here at Corel. I looked into it and found out that is is indeed a Microsoft problem : not ours. Other application have similar problems, not just CorelDRAW.

    The problem is with a windows API called GetGlyphOutline(). (http://msdn.microsoft.com/en-us/library/windows/desktop/dd144891(v=vs.85).aspx). For certain fonts like those mentionned here, it fails to return us the memory size we need to extract a character's glyph's curves.

    That means that any application trying to convert character to curves will fail. CorelDRAW requires that to display text object in enhanced view mode. Other view modes might still work. Convert to curve will also fail and the bounding box calculation of artistic text object will not work as well.

    We will notify Microsoft about this.

  • In reply to David Milisock:

    I can confirm, in my case anyway, that a simple uninstall of the offending update and a reboot will fix the problem with

    no system restored required using Win7 64 bit. I actually did it twice because I forgot to turn auto update off the first time.

  • In reply to RoyReed:

    The new update's working here too. Win7 64.

    Thanks to the Corel folks for helping to resolve this.