PostScript error when printing OpenType fonts in X6 - CorelDRAW X6 - CorelDRAW Graphics Suite X6 - CorelDRAW Community

PostScript error when printing OpenType fonts in X6

Hi guys!

I have a major problem with printing in CorelDraw X6...

I get a PostScript error (see below) when printing files that include some OpenType fonts (but not all, some print fine!) . So far, I got that error withTradeGothic and Formata, but I have not tested all fonts. Everything is fine if I print using X5. It a global problem, I tested many files with the same results.

It happens when I print a hard copy or a PDF but not if I "Publish to PDF"...

I really don't know much about PostScript error so I'm lost here.


As anybody else had a similar problem? Is there anything I can do?

  • Hi Julie!

    Can you send us the fonts in question and the .CDR file you are using so we can test it here pls? Can you also let us know which O/S you are using and which printer driver?

    tony dot severenuk at corel dot com

    Thanks!

    T.

  • In reply to Tony Severenuk:

    Hi Tony!

    Thank you for your reponse.

    I am using Windows XP with service pack 3 installed.

    I tried printing on printers using the Lexmark C935 Driver PS3 driver, Lexmark Universal PS3 Driver, HP Universal Printing PS (v5.1) and Adobe PDF Converter.

    Is there an e-mail address I could send the files to because they are too big to be attached here?

  • In reply to Julie:

    Here is a link to the files.

    http://dl.dropbox.com/u/72950530/julie_opentype_problem.zip

     

  • In reply to Julie:

    Thanks Julie!

    We'll give it a workout here and report back.

    T.

  • Julie:

    We can duplicate the error here with the font you provided. It happens on Windows XP only and it seems to be the apostrophe ( ' )  that's causing the issue. If possible, pls send us copies of all the fonts so we can test them and have the defect update accordingly.

    T.

  • In reply to Tony Severenuk:

    I thinks is not jus XP, I downloaded the try version 64 bits, and unstalled on Windwos 7, and it have the same problem, in this case with font Arial. I have some problems with the Switzerland font too,

  • In reply to Tony Severenuk:

    I printed a lot of files and so far, the only other font causing the error is Formata:

    http://dl.dropbox.com/u/72950530/Formata.zip

  • Just to confirm i've been having similar problems. We are on Windows 7 Ultimate using CorelDraw X6 32-bit. The machine we are printing to is a Xerox Colour 560 with a Creo RIP. I've had this problem come up a few times but it only clicked that this was the problem after seeing this problem. Converting all text to curves has always solved the problem in the past so i can only assume it is the same problem. Unfortunately the error reporting on the Creo is almost non-existant so it is hard to tell for sure. The font in this particular job that i've had problems with today is Minion Pro Medium, Semi-Pro and Condensed.

  • I'm also having this problem. 

    Reams of useless print out (which I've tossed). 

    Two printers attempted, both suffered the same failure. 

    My first project with x6.  Disappointing.  Never had this problem with x5; now, sadly, I've had to revert back.  I don't have time to muck around with this stuff.

    Hope it's a hiccup that gets fixed speedily.  Let me know when there's a solve.  Please.

  • Hi Julie,

    Thank you for the test file, it helped us to identify and fix the problem. It is caused by using certain high-range Unicode chars ( for example some 'apostrophe" chars ) in OpenType CFF ( PostScript fonts ), our font sub-setting would fail and result in either corrupted PS file or wrong characters. OpenType TrueType fonts are not affected. The problem is not OS specific, it can happen in XP, Win7 or Vista.

    The bug has been fixed and will be available in forthcoming SP1.

    Meanwhile, the workaround for printing is :

    1) go to PostScript tab in CorelDraw's Print dialog

    2) Uncheck BOTH "Download Type 1 fonts" and "Convert True Type to Type 1" controls in Fonts section

    3) You might want to make this setting change permanent by going to General tab of Print dialog and saving print settings : Save as.." button in bottom-right corner of the dialog. 

    This will ensure that we output all text as curves and no font subsetting is occurring. The downside is larger PS/EPS files which might affect printing speed (usually the difference is negligible).

    Hope this helps,
    Gennady

  • In reply to Gennady Petrov:

    Gennady,

    Thanks for your reply and the fix you provided. I will make those adjustments in my default settings. A big thanks to the Corel team for identifying this issue and fixing it. Keep up the good work. :)

    Raj.