• Not Answered

Can not reinstall Corel Draw x6

Yesterday I could not open any CDR files. I sent one to a colleague and she opened it just fine and resaved it for me. I still couldn't open the one she then sent back to me.

So I tried the REPAIR option for Corel Draw and that did not help. Then I tried to uninstall and reinstall, but this did not work. I uninstalled Corel Draw x6 and when I try to reinstall I get a message that says, " A newer version of Corel Draw is already installed. If you want to install this older version, first uninstall the newer version".

I had Corel updated to x6.3. How do I reinstall Corel Draw in this case?

This is the 32bit version I have installed as the 64bit version will not run on my PC at all. Win 7 Home Premium SP1 (64-bit OS)

Thank you.

~angel

4 Replies - Latest Reply

  • Angel,

    Look through this thread https://coreldraw.com/forums/t/38723.aspx?PageIndex=3

    Sounds the same.

  • In reply to bob:

    Bob,

    Thanks for the link. I read through that thread and it helped me to understand what is involved, but nothing helps. So far I have:

    Uninstalled Corel Draw x6 (rebooted)

    Uninstalled the Shell Extension (rebooted)

    Deleted the COREL folder in
    1) ...Program Files (x86)
    2) ...Users\Angel Roldan\AppData\Roaming
    (Empty the Recycle Bin + rebooted) 

    I have run a Registry Cleaner and it removed a TON of Corel entries (rebooted)

    I have searched the "C" drive w/ the keyword "corel" and deleted everything (rebooted)

    I am STILL getting that error. If I had hair on my head, I'd be pulling it out at this point - very frustrated.

    This is the dialogue I get:

  • In reply to theAngelRoldan:

    Hello,

    In the c:\windows\installer folder (it may be a hidden folder, so you may have to manually type it into Windows Explorer), enable the Title column, sort by title and check if there are any CorelDRAW Graphics Suite X6 components still installed.

    Please let me know your results. Sharon

  • In reply to Sharon Potts:

    Hello Sharon,

    Yes, I did look there. I had read through the thread that Bob posted earlier and I saw your post regarding those files/entries. I saw the files, right-clicked and tried "uninstall" but it gave me an error saying "this kind of file can not be uninstalled" or something like that. Sorry, I don't remember exactly as that was in the middle of a lot of doing-this-and-doing-that to try and get Corel installed.

    Anyway, I just now tried the x64 version and it has installed successfully on my machine. I checked EVERYTHING again and couldn't find a single trace of Corel except for the installer I D/L. I thought maybe since every trace was gone, the 64-bit version might install...and it did!

    I just opened the CDR file I was working on Mon. night (and couldn't open yesterday...starting all my problems...) and I am going to get some work done now, thankfully.

    NOTE: I did only install Corel Draw x6 and Bitstream Font Navigator since I can do without all the other apps in my workflow.

    Thank you both for your help. I appreciate it.

    ~angel