Problem with open/save/import/export dialog - CorelDRAW Graphics Suite X3 - CorelDRAW X3 and older - CorelDRAW Community

Problem with open/save/import/export dialog

 I just got a new system (HP wx4600 workstation with windows XP pro), and installed coreldraw on it. It works fine when I doubleclick on a file to open it, but whenever I invoke the common dialog box for opening, finding, or saving a file, it triggers the application recovery manager with the usual boilerplate about the application being unstable and you should save your work. 

 I've tried the usual things: reinstalling, installing the service packs, resetting the workspace, etc. The problem occurs even when I run coreldraw with windows in safe mode, and occurs in photopaint as well as draw. There isn't a problem when I open a file via the recently-used files list; it seems to come from that common dialog box for picking files. 

 Bulling through the ARM (hitting the cancel button) causes it to pop up several times, but I eventually get to a corrupted version of the common dialog box. This is semi-functional, and I can use it to open a file, after which things seem to work OK. 

 I've contacted corel, but I though I'd ask here too, to see if anyone else has ever seen this problem.

16 Replies

  •  FWIW, I figured out the problem. I use the microsoft "tweakUI" powertoy, and when setting up my new system I unchecked the "remember previously-used filenames" under the common dialogs settings. That caused the common dialog box in CorelDraw & Paint to cough blood and die when invoked. 

     Rechecking that setting fixed the problem. 

  • In reply to EKB:

    Man, you are GREAT!!! After 2 days of shout and almost crashed fingers i found your monologue! And last 3 lines save my day and my marriage!

    This solutions works fine for me, after tryng re-install, new video drivers and few kicks. Works for X3 and X4. !!!

     

    10x EKB!!!

  • In reply to EKB:

    It also solved the problem for me. You are a wiz. How did you figure this out?

     

    I checked the checkbox in TweakUI and Corel can be used again. Cool.

     

  • In reply to polarbear:

    How did I figure it out? Dumb luck.

    I was going through tweakUI for something else and happened to notice that the checkbox was unchecked. Since the checkbox was part of the dialog for opening and saving files, and since my CorelDraw problem was with the dialog for opening and saving files, and since I couldn't remember why I had unchecked the checkbox, I decided to re-check the checkbox and see what happened. And it WORKED.

  • In reply to EKB:

    Hi, I just signed up only to say a big THANK YOU to user EKB, your solution saved me from losing many hours of my work, thank you again man.

    LS

  • In reply to EKB:

    I noticed the same problem with a windows installation CD tweaked by nLite. Here is the registry entry if You not have tweakUI handy.

    ----------------------------------------

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies]

    [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\comdlg32]
    "NoFileMru"=dword:00000000

    ----------------------------------------

     

  • In reply to pirat:

     I like to say thank you to everyone on this thread for their postings. I have been trying to resolve the same problem since July. I contacted Tech Support and they were not helpful at all. The told me that I was the only one with this problem...knew that wasn't true. My "dword" was set to 1. By changing it to 0 problem solved....FINALLY!



    [edited by: rroth at 0:28 (GMT -7) on Fri, Oct 24 2008]
  • In reply to rroth:

    I'm having this problem but I haven't used Tweak UI, its occurring on networked machines being controlled by a windows server 2003 machine.

    admin & teacher users are unaffected but student users are. ive inherited the problem and trying to fix it, the fix the last person found opened up a security hole that id like to close.

    anyone know where in active directory this could be changing? gone through all the policies but cant find anything majourly differentely, well one thing the C drive is hidden for student users.

  • In reply to Krasim:

    hi guys... I am having the same problem with corel x4..

    The "first time" after  the installation that I run the program the  Corel ARM wizard shows over and over for 3 time. I started to reboot also  after installation but yet still it shows.

    I have tried using Tweak UI and checked the dword value and its already in "0"...but still my corel x4 crashes.

    I tried to install uninstall the prodect but yet the same problem occurs.

     

    Please help..

    I need Coreldraw to run Asap.

    Yahoo Msgr me pls: Jamaika_k05

     

  • In reply to Nwo_78:

    This sounds like a different problem from mine. I only got the ARM wizard when I tried to open, save, or import or export - anything that went through that particular dialog box. You sound like you're just having the ARM pop up right away when you start CorelDraw.

  • In reply to Krasim:

    Hello Krasim,

    I was in the same situation as you until a few days ago :)

    Solution is to navigate to 'User Configuration\AdministrativeTemplates\Start Menu & Taskbar' in server's group policy and make sure that 'Do not keep history of recently opened documents' isn't configured.

    Do let us know if it works or not.

  • In reply to Nwo_78:

    Nwo_78,

    Are all corel related service packs/updates applied?

  • In reply to samba_man:

    i completely forgot about this, i fixed my problem, it turned out to be Ranger, it was applying extra setting even tho i had told it not to, and one of the settings was the one you mentioned.

    solved it by turning Ranger off and just using it for user logging, im in the process of removing it from the system, i can do everything it does without having to pay for a licence for ranger.

  • A big thanks to the people who posted here, I have none of the programs mentioned here installed, yet I had the problem. I changed the regeristy key as someone above mentioned and that solved my problem.

     

    Thanks again it took me three days to find this post, without it I do not beleave I would have found the answer. Thanks again,

     

    Brandan

  • In reply to EKB:

    Just wanted you to know that even after a year of your post, you are still making people happy!  I just did your suggestion and it WORKED for my newly purchased X4 product.  I had X3 and never had any problems.  I was about to uninstall when I came across your link.  I had also contacted Corel Tech Support and they were of no help.

     

    THANK YOU A MILLION TIMES OVER AND GOD BLESS!!!!!!

    Happy camper in Kentucky,

    Mark :)