corrupt Corel X3 install issue

I am installing a new computer to replace my old one. I have installed CorelDraw X3 Graphics Suite on the new computer but when I try and run CorelDraw I get the message:

 

Registry Corrupt

The UI Language registration list is invalid.

 

If I try to run the CorelDraw X3 Graphics Suite CD1 and reinstall/modify/fix the problem I get a message that says “There is no language pack available”. I can uninstall the program via Windows XP Add/Remove but installing again just gives me the same error messages. I cannot find any help on this via Google or in Corel’s website.

 

I have checked the Regional Language Settings in Control Panel and cannot find anything weird or wrong. I have tried a few changes but nothing seemed to help.

 Please let me know if you have heard of this issue and how to fix it. 

I am running Windows XP Pro Service Pack 2 on a brand new computer from Dell (Optiplex 745).

 

Thank you,

Fred

 

20 Replies - Latest Reply

  •  Haven't heard this one yet. Have you contacted Corel support?

  • I found someone else having the exact same problem...you may want to look here:

    http://www.sawmillcreek.org/showthread.php?t=34763

     


     

     

     



    [edited by: MichelleDesslerFan at 7:54 (GMT -7) on Fri, Aug 31 2007]
  • In reply to Richard Reilly:

    I have not called yet. Based on what I have read on Google people having similar problems with Corel 12 and then upgrading to SP1 with the Multi Language CD's called Support and they admitted to the problem but did not have any solutions. I have not found anyone with Corel X3 and this problem until the next reply in this thread but it was a little different in the fact they were upgrading and I am doing a clean install on a new computer.
  • In reply to MichelleDesslerFan:

    I read the link you gave (thanks) and their situations were different than mine in the sense I am installing on a brand new computer never having Corel before and so I am not sure what step to take to fix the problem. I have a copy of the registry before I installed Corel so I have been uninstalling Corel and then restoring the registry prior to the Corel install. Is there a “UI Language Registration List” section in the registry that was corrupt before Corel was installed that I should delete and recreate or is there a file on the drive that is associated with the Windows “UI Language Registration List” that can be deleted? Is this section created under Corel in the Registry someplace and so this is not an issue because I am restoring to a clean registry before Corel? I have installed Corel so many times over the years on multiple systems and versions and have never had this kind of a problem before. We have always purchased retail boxes and have not had any problems before.  Any further help would be greatly appreciated.

     

  • In reply to Fred_B:

     I'm really stumped at this point...I really don't know how to help in this case. The link I gave was the best I could find that is similar to your issue. I don't know if the following will work...but you might want to try doing an image install of your CorelDraw X3 CD installation disk directly onto the hard drive. This involves using the expand command (if you have this on your version of Windows) if the CorelDraw CD has its own proprietary installers built in. This way doing a mirror install might prevent the language UI issues.

     However I'm reading that this issue with the Language Pack is something that CorelDraw is aware of but hasn't been able to find a fix. I was able to install my copy fine on my computer...no issues. I hope this doesn't happen when I have to install again myself. But this issue is scary because it proves that software may not always do as required when it comes to installing. I recently purchased Microsoft Office Outlook 2007 upgrade. When I installed the upgrade on my laptop...the program freezes without fail on initialization...and I've been using Outlook 2003 successfully for years. So I lost Outlook on my laptop. When I tried the upgrade on my desktop system...it worked like a charm. Something about installing on a laptop or desktop could be an issue you might want to look into as well.

     I don't know what kind of Dell system you're getting. It sounds like a laptop, right? If so...you may want to uninstall your CorelDraw X3 completely from the computer...and manually delete all traces of CorelDraw from the Windows Registry. Anything with the word Corel has to be wiped. Then try running Windows in Safe Mode with the CD support enabled and try installing CorelDRAW X3 that way. Reboot and see what happens.
     

  • In reply to Fred_B:

    Hello,

    can you confirm what the text of the file "volinfo.txt" in the root folder of your CD includes? It might help get you an answer.

    Gérard 

  • In reply to Gerard Metrailler:

    Here is what the volinfo.txt contains: 

    Product Name:   CorelDRAW Graphics Suite X3
    Platform:       Windows 2000, Windows XP (Home, Professional, Media Edition, 64-bit or Tablet PC Edition) or Windows Server 2003, each with the latest Service Pack
    Language:       English
    Media No:       CD 1
    MF No:          001
    Build No:       13.0.0.576
    Date Mastered:  December 16, 2005
     
    CorelDRAW
    Build No: 13.0.0.576 (\\Corel\CorelDRAW Graphics Suite 13\Programs\Coreldrw.exe)
     
    Corel PHOTO-PAINT
    Build No: 13.0.0.576 (\\Corel\CorelDRAW Graphics Suite 13\Programs\CorelPP.exe)

     


     

  • In reply to MichelleDesslerFan:

    This is a brand new Dell desktop.

     I may try both of your suggestions for installing from the local drive and from safe mode to see if that will work. Thanks for the input.

  • In reply to MichelleDesslerFan:

    I finally got it installed. I did a few things all at once so I am not sure which one made it actually work. I reverted to a Windows registry that was pre-Corel install. I deleted temp folders (I had done this before without success, but maybe along with these other things this helped.) I deleted anything in the registry that had any Corel words in it. (Not really anything much in the registry because it was pre-Corel install. A few Corel file association defaults from Windows I guess.) I tried to install in "Windows Safe Mode With Networking" but kept getting a message that a policy would not allow the install. I tried installing via copying the CD to the local drive but got an error that said the .cab file was corrupt. I did get it to finally install from the CD by logging onto the computer under a local profile name that had administrator rights not on my regular domain profile that also had administrator rights.With all that said - what really worked, who knows? At this point I am just thrilled the whole ordeal is done. My guess is the local account versus the domain account did the trick but not sure. Maybe all of this will help someone else in the future.

    Thank you for your input and help with this issue.

  • In reply to Fred_B:

    Hi to all

     Just downloaded the trial and I have the exact same problem - tried the above sugestions and it hasn't worked for me.  Installed the same downloaded files on the home PC and it works fine.  Any more clues as to what is going on?  During install, when the progress bar is indicating installing language packs I notice that it "rewinds" when it completes - something that didn't happen on the machine where the install worked.  There is also a missing folder in the start menu for documentation.

    Both machines are Athlons, both running XP with SP2 and updates.  The machine that works is using an nvidia card but this one uses an ATI card.  Apart from that they are similar.

     If I can get this working reliably then a purchase is a definite - I need to be able to open .ai files and re-save them for my XSI app.  Corel is excellent value compared to Adobe and will do this one simple task - if I can get it to work!

    Cheers

     

  • In reply to carlgmi:

    For those that follow - I fixed the problem thanks to another thread I found online.

    Open the c:\Programs\Corel\CorelDRAW Graphis Suite setup files\CGS13 directory and look for the EN.msi file.  Double click on this installs the language pack and then all is sweet.

  • In reply to carlgmi:

     i try to doit but i cant find this file in mi pc

    what can ia do  

  • In reply to shadowsakura:

    I know this is an older post, but for those of you running Windows 7 beta and trying to install Corel X3, you're going to run into the same problem, so I thought I would put in my two cents.

    To get X3 running, you perform the same step as stated above, HOWEVER you should run En.MSI from the Disc. it can be found in in CGS13 directory on the CD.  run EN.msi and you're all set.

  • Hi Guys

    My computor knowledge is pretty limited but having sat through the Ui Language problem on numerous occassions, I finally sorted it out doing the following:

    I Uninstalled all my other Corel programmes -been using different versions for a number of years)

    I then did the following:

    opened Local Disk (C:) - opened Windows File - Opened Temp Folder - and deleted all temp files that was permitted to.

    Restarted  PC and low and behold, after days of trying, success.

    Hope this works for u guys.

    Thanks for all your other efforts though.Let me know.

    Kind RegardsLionel

  • On your CorelDraw X3 Graphics Suite CD1

    browse inside the folder CGS13 for "EN.windows installer package"

    Install.. and the problem should be solved.