Corel A.R.M. won't allow Corel to open.

 This morning I was working on a file and saved it. Then I tried to open another file and the ARM kicked in and I had to save my documents and exit. Now I have a problem. Every time I try to start Corel again the ARM kicks in and shuts me down. I'm not even given the option anymore to save and then exit, it just tells me Corel has encountered a problem and will be shut down. I've tried some things to try to fix it...I've tried to use the setup disk to repair Corel, I've tried uninstalling and reinstalling Corel, I've tried to use system restore to roll back to a previous day to see if maybe that would help. I just can't figure out the problem.

I don't know if it's related or not, but when I try to send an error report to Corel I get a message after a few seconds  that the program could not communicate with the Corel website. Also, when I try to start Corel it wants to update my links but will not communicate for that either. Internet browsing and e-mail still works fine for everything else.

Has anybody else ever had a problem like this? 

16 Replies - Latest Reply by howellt

  • Hi Invizzible!

    Sometimes these problems can be related to a corrupted work space.

    Have you tried to do a reset of your workspace by holding down the F8 key while starting up CorelDraw?

    If not, you may want to give it a try.

    Rob 



    [edited by: willstu at 11:46 (GMT -7) on Fri, Jul 18 2008]
  • In reply to willstu:

     Rob,

    Thanks for that. I gave that a try and the workspace did reset to factory default. The splash screen showed up and I selected 'open file' and the ARM kicked in again. Dangitall. I thought we might have been on to something. After I've taken care of the last of my customers today I'll try some other things. In the meantime, if anybody else has any suggestions I'll gladly listen.

  • In reply to invizzible:

    Hi again, Invizzible.

    Sorry that didn't work for you.  There's one more easy thing to try, although I can't quite remember if version 11 has this option (my apologies if it doesn't). It's another one of those "standard" answers to similar problems. 

    Since you tried reinstalling, it might do some good to do a "repair install" if you haven't done that already (in your installation dialog), It goes through your installed files and repairs any that are corrupted or messed up by anti virus software, etc.

    I've had to use it several times for one reason or another and it often works well.

    Hoping this one helps,

    Rob

     



    [edited by: willstu at 17:56 (GMT -7) on Fri, Jul 18 2008]
  • In reply to willstu:

     Actually, when I decided that I may need to reinstall Corel, the 'repair' option was the first one I tried. When that didn't work I did a standard reinstall. When that didn't help I did a complete uninstall followed by what I thought was a pretty good clean-up of any stray Corel files (C:\Progam Files\Corel\anythingpesky etc, then a registry tool to rid myself of any leftover registry entries that may be causing a problem.) then did a clean install. I really thought I had it there but when I started Corel I got the whole splash screen and ARM thing again.

    Hmmm...if all of my Corel files are clean and I'm still having an issue, I wonder if something is haywire on my system that's making Corel act funny. FYI, Corel Paint, Trace, RAVE etc all still work fine.

    In the meantime I'm using my other computer to do my Corel work. Everything is running just fine on the other system.

    Thanks again, Rob.

  • In reply to invizzible:

    Hi Invizzible.

    I have a suggestion, close all of your apps and then go the system Temp directory and delete all the files and folders in there. The fastest way to get to the system temp directory, is to open the Run Dialog box and enter (without the quotes) '%TEMP%' and hit OK.

    You may be having a problem with disk space or may have a temp file that is interferring with Corel Draw startup.

    (Just a guess, here.)

  • In reply to Hugh Johnson:

     Wow, there were a lot of files in there. There were 50 some files with names 'carm1', 'carm2', etc that were text files containing the information the ARM will send to Corel in an error report. I deleted everything in that folder to no avail... still having the same problem. Thanks, tho, I never would have thought about the TEMP directory.

  • In reply to invizzible:

     If anybody has other ideas about how to resolve this problem I could still use the help. I've been able to keep up with my customers by using Corel on my other computer. That computer is pretty old, tho, and not the ideal machine to be working on. I'm still trying to get Corel to work on my main computer, tho.

    So, if I've done a complete uninstall and reinstall of Corel and I'm still having the same problem, is it safe to say the problem is with my computer itself? Maybe one of my system files is corrupted and it doesn't like Corel anymore?

    I am overdue for an upgrade. Would upgrading help, tho? This whole thing has just got me bumming.

    Thanks again!

    Paul

  • In reply to invizzible:

    At this point, me thinks some Windows file/service/dll is screwed up. I would try saving off all the good files (data) and then remove Corel (and other apps that are giving you problems). Then reload Windows onto the PC, overwriting the existing Windows, then load the various apps that you removed/want.

  • In reply to Hugh Johnson:

    Here's how I was able to fix the problem:

    From the start menu select Run and type %appdata%. The explorer window will have a folder named Corel. Rename the folder (ex. Corel Old) or delete the folder altogether. Close the explorer window. Start Corel and enjoy.

    I thought I had done a good job of clearing system folders of Corel files that might be buggy or corrupt but that one got past me. Now that I've started Corel again I've looked back in the Application Data folder and found the Corel folder is back...but whatever information is in there now seems to make Corel happy.

    I'll give her a good test run and see how she holds out. Thanks to all who tried to help. 



    [edited by: invizzible at 19:17 (GMT -7) on Wed, Jul 23 2008]
  • http://community.coreldraw.com/forums/p/2792/28819.aspx

     

    Work for me. I hope work for everyone here!

  • In reply to invizzible:

     Hi, I had similar problems and  had tried everything but your suggestion above worked. Now i'm really curious to know why it works, and what to do next time this problem happens? Call it Corel Old Old???Big Smile

  • In reply to Tassie:

    That's one way to do it, sure. However, if there was a file in that folder causing problems you probably wouldn't want to keep it as a backup. I did rename mine Corel Old and after making sure my problem had gone away I deleted that folder and there were no bad consequences.

    Also, let's hope that there isn't a next time and we don't need folders named Corel Old 1, Corel Old 2, Corel Old 3...

    Happy designing! 

  • In reply to willstu:

     Hi Rob

    This is Romy i saw your message to Invizzible and i have try that holding F8 key sugestion but nothing work well. I am facing the same problem. I have one most important file currepted. Do suggest me another idea that can i remove the error from my file.

    Please suggest me i am in big problem

     

    Romy.

  • Download TweakUI and go to Command Dialog, look on the right, check the Remember Previously-used filenames option. The Problem is solved.

  • In reply to bestest_boy:

    Actually, I have TweakUI on my system and I drilled down to the 'Remember previously used filenames' option and it was already checked. In my version of TweakUI the tab is called "Common Dialogs", not Command Dialog.

    I thought I'd also mention I still have problems with this once in a while where the ARM in Corel prevents the application from loading. The only way I have discovered to get things back to normal is by taking the steps I outlined in my earlier posts. The bummer part is that I lose all of my custom user settings and workspaces and color palettes.