• Not Answered

Error on Scanning a picture into Photo Paint X5

When I try to acquire an image from the scanner (HP F4400), the image will scan but before anything can be done, an error message pops up saying the server is busy and I need to switch to the other program.  I then have to go in to the Task Manager and close out of the program.  This is a personal computer but I do have other computers going through my router.  Is there a fix or work around so that images scanned can be imported to the program? Using Windows 7.

Frank



[edited by: Frank at 11:07 (GMT -5) on Thu, Mar 24 2011]

7 Replies - Latest Reply

  • Hi Frank,

    when you click on File>Acquire Image>Select Source, how many items appear? I used to have an HP scanner a long time ago and 2 things used to show up when I looked in Select Source; one worked and one didn't. I could be wrong, but I think one showed as a twain scanning device and the other showed as a WIA (Windows Image Acquisition) scanning device, which was the one which didn't work. They were both for the HP scanner though.

    Just check if you have more than one option and if you do, try a different one to what you have currently selected. You may even have a different device altogether set as the source device. Take a look at that as your starting point.

    Best regards,
    Brian.

  • In reply to Brian:

    Hi again Frank,

    as a second step I was going to suggest going to HP and checking you have the latest drivers. I had a quick look myself and when I found your scanner and looked in the drivers section...it asked me to select an OS and Windows 7 was not one of the choices. You may still want to check this out, as I only had a very quick look. How old is the scanner? Mine was an HP5400C and there were no drivers for Vista or beyond for that one. HP specifically even said on their site that they would not be creating an updated driver for Vista and that the user should consider buying a new scanner, which I did. The funny thing is, it actually ended up working in Windows 7, even though it did not work in Vista.

    I have no idea how old your scanner is, so this may not be an issue. Can you scan from any other application with this scanner (besides Photo-Paint)? Have you tried doing a scan directly from the HP scanning software? It  may not be a Photo-Paint issue, but more of a driver issue.

    Best regards,
    Brian.

  • This isn't a solution, but maybe some info that will help find a solution.

    I get that same error occasionally when I click a link to a pdf (using Firefox) and it tries to open it embedded in the browser.  Sometimes it just seems like Firefox is freezing & I can't see that error message/dialog box.  Other times I've been able to see that message and click the button to 'switch' and voila.. the pdf opens.  I can't tell exactly what is giving the error, but I'm suspecting it's from Windows and has something to do with OLE.

    When you get that error, have you tried clicking the 'switch' button?

    Hopefully other more expert folks will have a clearer answer.

  • Do you have another application that you can scan into such as MS Word just to check. Heck, I did not even know a scanner would work on a network.

  • In reply to Jack Ross:

    Jack Ross
    Heck, I did not even know a scanner would work on a network.

    Hi Jack,

    that HP model is a multifunction centre. I have a networked Epson multifunction centre and I can wirelessly (or wired) print to it, scan from it and send faxes from it from any computer on the network. I have never heard of a standalone networked scanner though; I am not sure if anyone has ever made one.

    Best regards,
    Brian.

  • In reply to Brian:

    I have the exact same problem on my HP4600 scanner.  The drivers on HP site are for Window Vista  from 2007.  A work around I found is switch to then select Photo Paint and it will open a second window.  Leave the other one running in the background and it seems to work.

    If anybody had a real solution, I would love to hear about it.

  • I have the exact same problem on my HP Photosmart C4400: a server busy dialog. It says

    "This action cannot be completed because the other program is busy. Chose 'Switch To' to activate the busy program and correct the problem."

    What is the "other program?", and how can you "activate" another program when you don't know what it means?

    The dialog box has three buttons but the Cancel button is greyed out, leaving "Switch To..." and Retry. I tried 'switching to' another Corel Photopaint instance but this didn't help. Retry also doesn't work.

    However, I only get the problem if I click Preview first.  Clicking Scan without previewing scans OK.

    It works fine with Adobe Photoshop CS5. This leads me to believe that the drivers are Ok.

    If anyone solves this, please post.