Wont Open File

I have Corel Graphics Suite 2018. When I tried to open a file today in CorelDraw, It simply locked up. It goes to the open dialog box, navigates to the directory, but when I select a file, nothing happens. I can't close CorelDraw, or exit out of the program or the dialog box. The only way I can close is to use Task Manager, and close the program. Can anybody help? 

No Data
  • I believe that I might have the same issue. It's related to DRAW and the Windows dialog. If I double click a file, it will open in DRAW and work fine. I can even save changes. If I try to open a file inside DRAW using the OPEN FILE dialog window... instant crash. If I try to SAVE AS (which opens the dialog window)... instant crash. The event log ALWAYS shows the fault being in the ntdll.dll when CorelDRW.exe tries to access it.

    I have run F8, repair, and uninstalled the whole suite including user settings to no effect. I even tried uninstalling the video driver thinking it might be related to the AMD issues people are having to no effect. I even tried opening a file while in safe mode but it still crashed.I updated Windows 10 to the latest updates, updated my NVIDIA card to the latest drivers, and still nothing.

    I would like to add that this happens to PhotoPaint also. So I'm skipping this version until I see a service pack or hotfix discussing this exact issue.


    System: i7-4790, 24 GB, Windows 10 Pro version 1803, GeForce GTX 1050 (driver 397.64)