Arial bold font keeps changing to regular.

I saw that someone had posted this two years ago, no answer. I only have this problem in CorelDraw, not in any other program I use. I created a booklet. I made many of the titles and lines Arial Bold. I keep having to go back and re-bold them after saving. It doesn't do it to an entire line, just parts. For instance if I bold "770-555-1234 •" the phone number may revert but the other part stay bold. I have tried doing it from the tool bar and from the side panel / text edit. No difference.

Any suggestions? I read the ones from two years ago, no help.

  • Arial bold font keeps changing to regular.

    Did you get any further on this?  I have exactly the same issue.  I believe its related to a bold version of the Arial font family but as you say no other program I use has this issue so is it just Corel....??.

    I think its possible that Corel is maintaining its own separate cache of fonts which has multiple versions, become corrupt or something.

    I am running X7, Win 10 on my work PC.

    In trying to find a fix I installed various versions of Arial that I found on various PCs that we have.  No joy at all.  Restarted PC, cleared registry all sorts of stuff.  Nothing worked.

    I found  an old PC running X5 so I created a file.  This machine and/or version of corel does not have the same problem. 

    The file contained 2 separate lines of text, one in Arial regular and the other in Arial bold.

    I copied this file to my main working PC with X7 and it opened with the fonts correctly bold in X7... hmmmm..

    I opened an X7 file that I need Arial bold in (but keeps disappearing).  I dragged the X5 file into this file and the X5 content stayed in bold - the X7 content stayed the same. 

    I saved the file (X7) and reopened.  X5 content stayed in bold.

    I change some of the X7 content to Arial bold and saved, closed, reopened and it was no longer bold but the X5 content was still bold.

    The 2 different (X7 vs X5) Arial content bolds are visually exactly the same and the name is exactly the same in corel.

    Corel MUST be maintaining 2 different versions of the font, in the same file!!! but with the same name.

    I havent restarted my PC yet..  who knows maybe a cache will be cleared and I will loose the bold after a restart but Id loose this post so I may be back to update later  : (.

    I found some strange things whilst working ion this. 

    I had ghost versions of several of the Arial types.  After all my deleting etc I am down to just a ghost version of Arial regular.  I cannot delete it.  If I do both get deleted and I loose Arial regular all together.  

    According to Font Navigator I have no Arial fonts all!!!.... just the Nova etc in the image below