Stuck at initializing screen during installation

I upgraded to Corel GS 2018 and am installing on a fresh clean version of Windows 10 Pro on my laptop. 2018 just sits at the initializing screen. I went through my purchased history, downloaded the installer for 2017 and it did the same thing. I removed the C++ libraries that were installed and tried both again, neither got past the initialization screen. I went back to the purchase history and downloaded the X8 installer. I worked like a charm, so I at least have X8 installed on my laptop, but I really want to get 2018 installed there. 

I sent in a support ticket, but was hoping that maybe somebody here has seen the same thing. I can't believe that I'm the only person who has run into this issue. There wasn't a thing on the OS, CorelDraw was literally the first application getting installed outside of Firefox. 

Any ideas?

  • I had the same thing happen. The install screen is too small to display the buttons to continue. They are there, you just can't see them. Use the "tab" key to navigate around the screen, which will move to show the highlighted button, then use "Enter" to activate that button and continue the installation. Mine has worked fine after that initial problem.

Reply Children
No Data