What the Font is not working.

There has been no update or anything.  I get an error that states "Your computer may not be connected to the internet or you may have  a firewall installed that is blocking access to the internet."

  • You're not the first to notice this.....

    I think it's a problem outside Corel, and I hope they're aware of it.....

  • Same problem here. Been like that for some time now. Have tried various things to fix it, but no joy as yet. Hoping for a fix soon.

  • I see the same thing.  Turning off firewall, setting up exceptions, etc. all do nothing.  And obviously connected to internet so that part is incorrect as well...  

  • I contacted CorelDRAW a month ago. The state they have escalated this issue to another group and I’ve been waiting patiently. 

  • Not working here either, same error message.

    I suggest you give up WhatTheFont (I did, years ago) and try Find my Font instead.
    It is a standalone app, not too expensive, that search for fonts based on an image or a screenshot, and compares with fonts stored on your computer and also from a huge online database.
    It is often very accurate and with a few extra steps it can also search when text sample is rotated or deformed.

    I suggest you give it a try.

    Edit: I found now that they have created free mobile versions for both Android and iOS.