Macros not working CorelDraw 2020

I used to use a Macros in older versions of CorelDraw for my laser cutting files. I use the default black as my cutting colour and magenta as my "drawing" or "kiss-cutting" colour.
The macro would change the outlines I selected to magenta with a keyboard shortcut. I would change multiple or single lines with one button click.

This was the macros I recorded that worked for previous versions of CorelDraw:

Sub Colour_Change()

Dim OrigSelection As ShapeRange

Set OrigSelection = ActiveSelectionRange

OrigSelection.SetOutlineProperties Color:=CreateCMYKColor(0, 100, 0, 0)

End Sub

I figured maybe they've upgraded to a newer macros language so I rerecorded a new one, but it still doesn't work. This is what it creates when I record the same actions as I did a few years ago:

let OrigSelection = host.ActiveSelectionRange;
OrigSelection.SetOutlineProperties(-1, null, host.CreateCMYKColor(0, 100, 0, 0));

I found a work around where I could create a custom object style and assign the colour to magenta with a keyboard shortcut, but then I have to import the style set file for each document I create. Not the end of the world but I miss the macros that remained on every document I created. Just wondering what I need to do to recreate this macros effectively.