After 27 years of CorelDRAW, I have never seen this...(crashing)

I am a charter CorelDRAW user since version 1, and I have used CD daily since 1995.  I love the program.  I have been through every version, up to my current 2020 version.  I have been through stable and terribly unstable versions.  I have been through the pain of a file becoming corrupted many times.  But in general, all of those things have settled down for me for quite a while now with only the occasional shock of a complete crash.  I have not had a file corrupted in years.   Due to all of the above, if I have a supercritical project, I have a fanatical commitment of saving my files and saving them often, but more than that, I save versions of my files as I work (example:  filename-v001.cdr, filename-v002.cdr etc).  I generally save each version after about 10 mins worth of work, because nothing kills my inspiration and work spirit like having to REDO any....any amount of work.

Today I have encountered something I have never seen before in any version of CorelDRAW.   I completed the design for a vehicle wrap and exported the files in multiple formats for the installer.  The project was 100% done and in the bag.  I pulled up my PDF files just as a due diligence check before transmitting them to the install shop.  There was something in the export I did not like so I decided to redo the exports.  The issue is not central the problem I am reporting....I say all of this just to let you know everything about the entire design, the work sessions, etc...all went 100% as expected with no issues, whatsoever. 

 Until I opened the CDR files again.

FYI....I had saved 11 different versions of the file as I worked, just today alone.

I opened "v011" (the 11th version) to do some tweaks....but CorelDRAW 2020 struggled....and would not actually open the file.....I left the computer running, had some lunch and returned.   The file was still not open.  So I used Windows Task Manager and killed the program.   The problems only got worse.  I tried v011 again....and Corel INSTANTLY crashed after the splash screen.  I tried a dozen times.... absolutely identical crash after the splash screen EVERY TME.  I then did the following:

1.  System cold reboot.  - Problem persisted
2.  SF8 reboot - problem persisted
3.  Software uninstall/modify - problem persisted.

This sounds normal...for "problems" and that too is NOT the unusual part.  This is the unusual part....

I then resorted to opening version 10....crash.  Version v009....crash....v008...crash....all the way down to version 001....which opened successfully.  I then proceeded to spend 2 hours recreating the file.   I completed the entire project and exported all formats of files as previously done.  Successful....almost.

Because I also send the CDR files to the installer, I thought I should double-check THAT file for any problems by simply reopening it.  CRASH....

Repeated EVERY step from above...every step....this time 7 versions....each and every one crashed CorelDRAW.

So then I decided to outsmart the process....and I went back to version one....and saved it as a CDR v2019 file format.  I then opened CD2019 and spent 2 hours rebuilding the files AGAIN.....

I completely finished the file/project.    Exported the file just in case.

Reopened the CD2019 final file.....crash....  NO WAY???  NO **** WAY.

I have seen a lot...but I have never seen all of this on EVERY version of a file AND ON TWO different versions of CORELDRAW....

I am out of clues on how to get passed this issue.

I run CorelDRAW 2020 on Windows 10, which is installed onto a MacBook Pro via Parallels.   I have had this set up for years with much success and quite honestly almost never any real issues at all.

My next troubleshooting attempt will be to try and open the files on a different computer altogether.

Is this unique to other forum users as well?  What would you do next?