HELP! Corel X5 Draw Crashes with Runtime Errors in Bitmap PowerTrace

I'm converting a BMP to High Quality Trace/Contour. It worked fine until a week ago, then started to degrade.  First it only crashed once I adjusted the sliders to what I wanted, never completing.  Now the runtime error pop-up show up and freezes the program the moment the PowerTrace GUI shows up or starts to process the default trace setting and just sits at about 10%.

I've checked my Win7 Events logs and while the runtime error detail can vary a bit, they are more or less the same ones over and over.

I've updated my Visual Studio 2005 and 2008 (the ones native to X5), no go.  So I uninstalled and re-installed the entire Studio Suite.  Still no-go.

If I can't fix this, I may need to re-install my older Graphics Suite 12 but having rarely used Draw then, I don't know if the PowerTrace is available or as tweakable as in X5.

This is a bit frustrating for my project is 99% completed and needs this last conversion.

What could be interfering/causing this?
Thank you.

~ Philip