Issues with Mouse in Corel PhotoPaint X6 (Windows 8.1)

Serious mouse issues...

Hi. New to this group so I hope I'm asking for help in the right way.

I am having SERIOUS mouse issues with Corel PhotoPaint X6. I am SOOOO frustrated it's insane. First... a picture to illustrate...

 Here's the problem. I wanted JUST to draw the circle on the map but instead of the starting where it says wellington avenue, the paint brush begins at the top of the page, draws a line to the start position then draws the circle as I make it. Quit drawing, start again, same thing happens... a "tail" above the circle. So... I' so frustrated that I go to CorelDrawX3/PhotoPaint and SAME thing happens. I dump the mouse drivers, reload them, try again. STILL a problem. Same problem for ALL tools which draw (eg clone tool) AND as I said, this is happening in X3 as well. Reinstalled mouse drivers AGAIN. YIKES! How can you use a paint program which doesn't allow you to paint where you want it to????

I also posted this in X3 or earlier (I think) AND further to above info, look at this... I tried over and over (left, below) to stop line tail (was cpt saved as jpg) then saved to show to you people. Once saved, I was able to draw circles without tail in jpg. Loaded cpt map again and circles without tail. STILL a problem because unpredictable... what do I do to PREVENT this??

No Data
  • Just had same problem.  I tried pressing "F8" during launch, to reset workspace, but didn't fix the problem.

    Problem was corrected *NOT* inside COREL, but in WINDOWS 10 instead... in "Display Settings".  I noticed that the "Scale for texts, apps & other items" on my screen was set to 125%.  Once I changed display's SCALE back to 100%, the problem disappeared.

    Please notice that it's *not* Display's resolution I'm talking about, but another setting called "Scale and Layout".

    I found that issue returns every time I connect my laptop on its dock station, because I have a 2nd screen connected there, and Windows10 changes display's settings automatically.  But at least I know how to fix it now.

    Hope this helps anyone.