Corel PhotoPaint X7 appears to start OK but then drops to Task Bar with no Full Screen display. Other Corel Programs open up OK.

Corel PhotoPaint X7 suddenly failed to display a Full Screen but can be seen in the Task Bar.    All other Corel X7 programs open OK, ie. Draw, Capture etc.     Tried opening whilst holding down F8 but still no success.      Complete reload of Corel X7 still produced no change. 

 Interesting observations however are 

(1)  Many Adobe Script Error Messages appear when I try to open PhotoPaint.   

(2)  My backup graphics program Picaso also fails to provide a full screen display.     

(3) The very annoying Corel Ad that appears on starting PhotoPaint displays a blank Window  with "Biggest savings of the year": at the top but no graphics or image.   

The Version I am running is CorelDraw Version        Can anyone help?


  • After several more reloads of Corel X7, and 2 System Restores, deleting Adobe Flash Viewer Corel suddenly opened up to a Full Screen!!!!!!

    Unsure why this problem suddenly appeared nor confident as to why it suddenly disappeared, but am happy it is again working.