Urgent - problems in PDF specifically in x7 - Small Caps

I have to submit my 230 page book, (which i crazily designed in Corel ) to the publisher this week for editing and copyediting. They do not work with Corel and they need to be able to copy the text into MS Word for editing. I formed my pdf embedding the fonts (the pdf looks perfect) and did a test to see if i could copy and paste from the pdf to a word processing program. All worked fine except for the words I used in small caps. These came out as nonsense symbols. I tried changing under Document in my pdf setttings to Asci 85 but same result. All works well except for words that are in small caps. ( i have small caps in all my chapter openings);.

I noticed in Corel X5 there is an option when publishing to pdfs under the  Objects tab in the pdf settings for UNICODE  ( as opposed to Asci). I did a small test with this in x5 and it worked fine - Small caps that were copied and pasted from the pdf appeared perfect. My problem is getting this result in X7 as I don't see this option in x7s pdf settings. Am I missing something? it is hard for me to imagine an upgraded version would allow for less options.

I could in theory save all my x7 files as version 15 and work from x5 but that might cause unnoticed screw-ups and besides it is difficult to work in Windows 10 with x5.

Any advice ( need quite urgent) how to get these results in x7?

Thanks in advance