Corel A.R.M. won't allow Corel to open.

 This morning I was working on a file and saved it. Then I tried to open another file and the ARM kicked in and I had to save my documents and exit. Now I have a problem. Every time I try to start Corel again the ARM kicks in and shuts me down. I'm not even given the option anymore to save and then exit, it just tells me Corel has encountered a problem and will be shut down. I've tried some things to try to fix it...I've tried to use the setup disk to repair Corel, I've tried uninstalling and reinstalling Corel, I've tried to use system restore to roll back to a previous day to see if maybe that would help. I just can't figure out the problem.

I don't know if it's related or not, but when I try to send an error report to Corel I get a message after a few seconds  that the program could not communicate with the Corel website. Also, when I try to start Corel it wants to update my links but will not communicate for that either. Internet browsing and e-mail still works fine for everything else.

Has anybody else ever had a problem like this?