Cannot get the Corel X6 Upgrades (6.1 - 6.4 Hot Fix) to install

Hello. Up until yesterday, I was the happiest kid on the planet. CorelDraw Suite X6 was working fine and, aside from the rest of the crap going on in the world, my workstation was buzzing along nicely. In an attempt to fix a Windows 7 security permissions issue on an unrelated folder, I screwed up an got into something I probably shouldn't and messed up my access to several programs. CDX6 among them. It would not run, telling me some files could not be found and I did not have access to several others. A system restore did not solve the issue. Running the Windows (return all files/folders permissions to the default settings) fix did not solve the problem. Attempting to uninstall X6 didn't work because all I got was 'Access Denied'. Attempting to delete the directory gave me the same error. As a last ditch effort, I re installed X6 into the Program Files (x86) directory as opposed to the straight Program Files directory where it wants to go. It ran but then I tried reinstalling the service packs from 6.1 to 6.4 and 6.4 Hot Fix. I couldn't because 6.1 kept taking me to my account sign in screen to log into my account, but once I put in my user name and password, nothing happened. The screen did not change. It did not move. Corel Customer Support Chat guy named Bhutu kept typing the same response, word for word when I asked him for help. Legacy version no longer supported have a nice day. I got CDX6 running after using a program called Unlocker that deleted the entire Program Files>Corel directory. Then I uninstalled X6 yet again and then reinstalled it back into the default directory and tried the service pack upgrades again with the same result. I can live without the upgrades, but there are two neat features in the 6.4 upgrade that are very useful. Sorry for the length of this, but is there is anyone who has seen this or knows what the fix might be, I'd appreciate it. I even disconnected the wifi and tried without but it errored out saying I needed a network connection to conrinue. I can get into my corel account at fine, but this is really strange. I have had this program for years and have uninstalled before and done the upgrades before and never had this issue. Thanks.