Image Cutout continuously crashes when pressing "Ok"

Well, I thought I had fixed this problem, and even responded in a couple other posts that it was working again. I was wrong. I had cleaned my registry and the program (PhotoPaint X7) loaded faster, and when I tested cutout lab on a small PNG file, the preview worked, and when I clicked "Ok", it also worked perfectly. So I thought the registry cleaning fixed the issue.

However, when I open a larger image (not huge, just something like 1024 x 768 pixels....and use image cutout lab, I'm able to preview it just fine. BUT...when I click OK, the program crashes. I tried to do the F8 when starting the program, but I couldn't even get that function to work. Maybe I was doing it wrong? I pressed F8 while clicking on the PhotoPaint shortcut, and a dialog box popped up asking if I was sure I wanted to revert the workspace to default. When I clicked "Yes", the dialog box disappeared, and Corel didn't open.

I read online to go to Uninstall a Program, double click on Corel Graphics Suite, and do a repair, which I did. Still, cutout lab crashes anytime I use it on a graphic larger than 200x300 pixels. Again, the preview works fine, but when you click "Ok" to complete the cutout, the program crashes. Seems like some sort of memory issue, or a software conflict of some sort. I'm using .NET version 4.8 so that MIGHT be the problem?? I can't remember when the crashes began because while I use PhotoPaint almost every day, I don't have need to use cutout lab all the time. Could be a month in between uses, and other software or changes to the system take place during that time, so I can't trace a specific action to the cause.

I have 16GB of high speed memory installed in the PC, along with a high-end graphics card (I do graphic design for a living). The cutout lab used to work perfectly, so there's apparently a conflict somewhere. My guess it's not hardware related because no changes to the hardware have been made since it last worked. I know others on the forum have experienced the same issue, and no answers were given that resolved the problem. LOL...I'm not holding out much hope for Corel to come through with a solution (based on what I've seen in other threads....but I'm an eternal optimist.)

So Corel, any ideas what might be causing it?? I'll keep testing on my end (disabling certain programs to try and identify any conflicts, etc.)...and will update this thread if I find anything.