Enable Ligatures? Symbol is not bold under Object Properties

I may have turned off Ligatures. Purchased monogram fonts and they won’t intersect, etc. Designer says to make sure Ligatures are turned on. Tried selecting text with the monogram font. Under Object Properties the “fi” (no dot over i) symbol is not bold and when I click on “fi” the message says >  “Standard Ligatures This feature is not available for the selected font”. None of the symbols at the bottom of the page under Object Properties are bold... any ideas? It’s usually something simple I am missing or accidentally unchecked. Thank you for helping!