Fix for being accused of stealing CorelDRAW!

I had an disappointing experience with Corel today. CorelDRAW/Photo Paint started displaying an "Illegal Software" message offering me amnesty and such.

Since I don't steal software and was offended at the implication, I contacted Corel by chat.

They asked for my serial number, which I gave them, but accidentally gave my X7 number from which I had upgraded. The rep then went on to tell me how my serial number was not for the version I was using. I was offended at the implication.

Now, bearing in mind that I bought X7 and the upgrade to 2017 from Corel, and should be in their system, I dug into my records to find my copy of the receipt to prove my innocence. That didn't sit well with me, either.

So, then, the customer service guy tells me to do this:

<quote>Delete Corel message folder to correct the issue.

1. Press Windows key + R.
2. Type %appdata% and hit enter.
3. Go to Corel folder
4. Delete the "Messages" folder </quote>

That worked. The accusational message box no longer appeared. So I asked, why didn't the service guy suggest that first instead of making me jump through all those other hoops to prove my innocence and what the ^ happened in the first place to provoke the software-theft-accusation dialog box.

None of this was cool or professional from Corel. None of it.

Anyway, rant aside, there's the fix if you get accused of stealing your software by Corel.


No Data
  • Okay--the same problem has just happened to me, and my response is the same as most of yours. Aggravated. Appalled at the horrible Corel customer service. And VERY annoyed at Octavian's comment that we complainers are "candy ass snowflakes." Not wanting a hedge-fund-run corporation to enter my personal world and disable my much-loved and legitimately purchased property is pretty reasonable. Shame on Corel, stop being so angry, Octavian, and many thanks to SeanB, whose advice I just tried and it WORKED. By the way, Corel has ignored two emails and wasted my time on one chat session. Two days since I first reached out through Corel Support, and I have heard nothing from them on how to fix this problem.

No Data