Any way to turn "automatic spell checking" off?

Not a big thing though, but settings won't save with it ticked off and i need to change this for every document, every time i open it. I've already tried "save settings as default" but no luck. It used to be a "general" option before. Is it only me or anyone can confirm this behaviour?