Can't change default font

I've had my default font set to Adobe Garamond Pro for years. Every upgrade I reset my default font to Adobe Garamond Pro. This morning I open a new document and the default font is Avant Garde. I have been trying to reset the default and as soon as I make any selection of anty font, the selection returns to Arial--not Avant Garde and not the font I am selecting. The only way I am able to change a font is after I've typed something (artistic or paragraph) I have to select the text by inserting the cursor and highlighting it.

1) I've tried rebooting,

2) Changing the default  via styles

3) Changing the default via the text tool with nothing selected and with closing all documents and starting a new one without putting the cursor on the page

4) Deactivating the fonts and reactivating them, both through the OS and through Corel font manager

5) I've tried OT fonts and TT fonts

6) I've tried dozens of different fonts

7) Everything works in Illustrator.

8) Once I try to change the font from Avant Garde to something else, it switches to Arial and then I can't even reset it to Avant Garde without closing Corel and reopening it

What gives? Any ideas? This is making me crazy.