Stuck at initializing screen during installation

I upgraded to Corel GS 2018 and am installing on a fresh clean version of Windows 10 Pro on my laptop. 2018 just sits at the initializing screen. I went through my purchased history, downloaded the installer for 2017 and it did the same thing. I removed the C++ libraries that were installed and tried both again, neither got past the initialization screen. I went back to the purchase history and downloaded the X8 installer. I worked like a charm, so I at least have X8 installed on my laptop, but I really want to get 2018 installed there. 

I sent in a support ticket, but was hoping that maybe somebody here has seen the same thing. I can't believe that I'm the only person who has run into this issue. There wasn't a thing on the OS, CorelDraw was literally the first application getting installed outside of Firefox. 

Any ideas?

  • Hello, first of all sadly I have no solution, but the same Problem as you.

    I was using Corel X8 but after some updates it stopped working well, so I decided to reinstall it. After removing everything with the Revo Uninstaller tool, I tried to reinstall but every time the installer gets stuck showing initializing setup please wait. I also tried an older version of Corel and even the new Technical Suite 2018 but all of them seem to have the same problem. Therefore, if you get an answer from your ticket or find a solution to this problem I would be very thankful if you could share it.


Reply Children
No Data