Corel Draw 2019 - Super slow file opening and editing - Very unstable


I am running Corel Draw 2019 on Windows 10 and have yet come across another mind-numbing issue. I am working in a file just fine, then I perform an action, such as import or transparency, and I get the spinney wheel of death. Go to Task manager and Corel is not responding. Sometimes it will eventually perform the action after an extended period of time (4-5 minuets) or nothing at all. Force quit. Save Auto backup of file when I reopen the program and then every action takes forever, if at all. This is very frustrating. Any insight would be most helpful. Thank you!

  • I upgraded from X5 to 2019 5 days ago. It will not work. So buggy. Will not open my X5 files. Just sit there with the little circle spinning and spinning and then goes into "not responding" mode. I have tried everything..Uninstalls including removing all corel folders.. repairs..restarts presing F8..with no good results.  My X5 still works fine.. My PC has 16GB Ram..Plenty of hard drive space and processing speed..I have even created some very simple files in 2019 and it will open some, but not others. I have been messing with this and wasting time for 4 days now. I have also right clicked the desktop icon and checked for "compatibility issues". Did a test revert to Windows 8 as I am running Windoes 10. STILL no good result. Contacted support via chat last night. Went through recommended steps of renaming CorelDraw 2019 to .old, then doing repair. STILL the same. I've uninstalled the old X5 completely and ran 2019 by itself.. STILL the same. I even bought a new graphics card thinking it was the problem. STILL the same. I have reverted my graphics card driver to a previous version (as seen on a youtube video) and STILL not working. Now I have a ticket created where I sent them my computer files as requested and still waiting to hear back. I have  project I am working on that is being delayed. I finally just reinstalled my X5 (after removing thinking a conflict existed) so that I can proceed with this project. In addition I received a 'free" version of  Painter Essentials 6 and it will not even install. It wants to find the .msi file, saying it is missing. Seems like the network link they sent to me does not work. Also the Font Manager locks up just like CD2019. I tried to simply remove 1 font and it just freezes. I am at wits end with this and have spent way too much time trying to figure this out. I it rediculous that I have to do this. After all isn't it an 'UPGRADE". Seems like a downgrade to me. If this is not fixed very soon, I will ask for my money back and simply use X5. Has anyone else experienced this and found a solution.

  • I upgraded from X5 to 2019 5 days ago. It will not work.

    I can understand your situation.And naturally, it is not normal or acceptable. There are some things that catch my attention, for example that Painter Essentials has not worked well either ... it has no relationship with CorelDRAW, so maybe there is another reason. Do you have all the Windows updates installed, including the .NET Framework? I suppose so, but it never hurts to ask.

    It also does not open FontManager, which may be another different problem, but it may be linked. How many fonts you have installed? You can use the FontNavigator of X5 to verify it. It is recommended to have few fonts, FontNavigator warns you if it exceeds 400 but the legacy limit of Windows is 720 fonts (although it may have thousands installed, some could doesn't work)

    On another topic, although it is not related to it, I talked about Virtual Memory and how beneficial it can be to establish a larger size (it has nothing negative, it only takes up a little disk space). It may not be the specific solution to your problem, but it may still help.

    A possible explanation could be related to the fonts. If FontManager monitors the entire disk, the overall performance drops significantly, however if you place the fonts in a single folder, separate from Windows / Fonts of course, the result will be much better. Perhaps there is a particular font that is damaged ... it is impossible to predict.

    I remember that in previous versions, a user had a similar problem (the program was blocked at startup) and the solution was to change the default printer in Windows. Sounds strange, I know, but it worked. I know I haven't given you any concrete solution, but at least you have some ideas to try and tell us.

Reply Children